Troubleshooting | Slow UCI Touch Screen Response
Learn how to diagnose and solve problems with slow touch screen response on UCI devices.
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Table of Contents
Problem
UCI Touch Panel response is slow or lagging.
Causes
- High number of control elements in the UCI that may effect processing resources
- Image resolution is too high for touchpanel resources
Solution | Workaround
- Replace any video preview windows on the UCI with the Media Display released in Designer 9.2.1
- Reduce any multi-page UCI's to a single UCI with multiple layers
- Reduce the overall number of control elements in the UCI
- Avoid excessive TSC graphic asset scaling up or down in size. Graphic assets should closely match the resolution of the target asset resolution.
- Generally background images should be scaled to closely match the resolution of the panel.
- Button backgrounds and icons too should generally match the resolution of the button object.
- Set the UCI's Swipe Disable to Yes and Enable Button Swipe to No if possible
- Avoid multiple UCI Layer Visibility Transitions happening at the same time
- Reduce the number of active VU meters in the UCI to lower the data received by the TSC panel
- Avoid using VU Meters using the Segmented Meter type