Troubleshooting | Softphone Dialer not working as a pin pad in Q-SYS 9.0.0 and later
Learn how to solve issues with using the Softphone dialer as a pin pad in Q-SYS 9.0.0 and later.
Affected Products
Hardware Model/Series | Core processors |
Software | QDS 9.0+ |
Problem
Softphone Dialer not working as a pin pad in Q-SYS 9.0.0 and later.
Causes
Changes to the program architecture requires additional configuration to use softphone dialer as a pin pad.
Solution | Workaround
If your Softphone Dialer no longer works as a pin pad after upgrading to Q-SYS 9.0.0 or later (i.e., you see a configuration error and the dialer no longer allows button presses), try the following.
Use the PIN Pad component in place of the Softphone Dialer.
For more information, see the PIN Pad topic in Q-SYS Help.
- Navigate to Core Manager > Network > Basic.
- Note the Core's IP address for the network port configured in the Softphone setup. If you are unsure which interface is used, note all IP addresses.
- Go to Telephony > Softphones and click Edit.
- In the Softphone Configuration:
- Set Register with Proxy to 'No'.
- Enter the Core's IP address in the Proxy field. If the Core is set to use LAN A as the network interface for the Softphone, enter in the IP address of LAN A in the Proxy field.
- Click Save. The Softphone will now show a status of OK.
Now the dialer can be used as a pin pad without having to make any other modifications to the Softphone or Core