Troubleshooting | CX-Q amplifier shows the wrong model on the front panel and in Designer

Learn how to diagnose and rectify an issue with CX-Q amplifiers that are displaying the wrong model name on their front panel and in Designer software.

Updated at May 8th, 2023

Affected Products

Hardware Model/Series CX-Q Series
Software QDS

Problem

CX-Q amplifier shows the wrong model on the front panel and in Designer.


Causes

Unknown firmware issue.


Solution | Workaround

In the rare case that a CX-Q amplifier shows the wrong model number, follow this procedure to resolve:

  1. Back up your existing design file.
  2. Perform a Pinhole Reset of the amplifier. Refer to the User Manual for instructions.
  3. Using a different major release version of Q-SYS Designer, create a new design containing only the CX-Q amplifier and Q-SYS Core. The Designer version can be higher or lower than what was running previously - for example, 9.0 to 8.4 or vise versa. For the CX-Q amplifier name, use the factory default Device name as shown on the front panel or in Configurator.
  4. Save and run the design to the Core.
  5. Configure the amplifier's IP settings and host name as desired using either Configurator or Peripheral Manager, depending on the Q-SYS version.
  6. In the desired version of Q-SYS Designer, push your original design.