Troubleshooting | Test connection fails "Step 1" when registering Core to Reflect

Testing HTTPS Connection - getaddrinfo failure Troubleshooting

Updated at August 24th, 2023

Affected Products

Hardware Model/Series All
Software All

Problem

Core failed Step 1 when performing a Test Connection to Reflect Enterprise Manager. 

Failure message seen is "getaddrinfo EAI_AGAIN reflect.qsc.com: 443


Causes

the getaddrinfo must provide translation from an ANSI hostname to a real address, which means DNS is not working properly.


Solution | Workaround

  • Verify DNS is enabled on your core
  • Verify your core can ping the Reflect server. You can also try to ping another site like ‘google.com’ to prove the core can reach outside the network.

Reminder:
S requires DNS (port 53), NTP (port 123), HTTPS and WSS (port 443)

Proxy Servers or next-gen firewalls can prevent connections

SSL inspection needs to be disabled for Core-Reflect communication